Resolved
The bank identified the issue was rooted on their side and have confirmed they've fixed it.
Monitoring
While the bank hasn't gotten back to us, the institutions appear operational so we've enabled them back.
Investigating
We have disabled the institutions while we wait on Citadele to get back to us with more details.
Investigating
We are seeing issues with Citadele. The root cause is yet to be determined, we have reached out to the bank to investigate. Updates will follow.
Affected institutionIds:
CITADELE_PARXLV22
CITADELE_INDULT2X
CITADELE_PARXEE22