Investigating
Our engineering team has reached out to the bank for additional details and we're currently waiting on the bank to investigate.
Investigating
We are currently experiencing connectivity issues with Bank of Cyprus (Bank id:BANKOFCYPRUS_BCYPCY2NXXX), and the integration is temporarily non-operational. Our engineering team is actively investigating the root cause to restore full service as quickly as possible.