Monitoring
The bank has launched adjustments. We are currently monitoring performance.
Investigating
OP Financial Group is experiencing request issues. Our Development Team have contacted the Bank to get this resolved as soon as possible.
Affected bank id - OP_OKOYFIHH