Yearly eIDAS certificate updates and Impact on institutions.
In progress·Under maintenance

Tue, Sep 9, 2025, 09:06 AM
(1 week ago)
·
Affected components
Cyprus
Czechia
France
Hungary
Netherlands
Poland
Romania
Sweden
United Kingdom
Updates

In progress

Tue, Sep 9, 2025, 09:06 AM

In progress

Due to a certificate change for Addiko Bank (ADDIKOHR_HAABHR22), existing consents will be lost on September 9th after 13:00 BST. To gain access again, accounts will need to be reconnected.

Tue, Sep 2, 2025, 12:55 PM(6 days earlier)

In progress

Due to a certificate change for Bank Pekao (PEKAO_PKOPPLPW), on 28 August after 8am UTC (11am GMT+3) existing consents will be lost. When this happens, please reconnect the accounts.

Tue, Aug 19, 2025, 07:12 AM(2 weeks earlier)

In progress

Due to a certificate change for Bank of Cyprus (BANKOFCYPRUS_BCYPCY2NXXX), on 28 August after 8am UTC (11am GMT+3) existing consents will be lost. When this happens, please reconnect the accounts.

Mon, Aug 18, 2025, 01:18 PM(17 hours earlier)

In progress

On 21 August at 11am - 11.30am (GMT+3) there will be downtime with Gránit Bank (GRANITBANK_GNBAHUHBXXX) due to certificate change.

Wed, Aug 13, 2025, 07:43 AM(5 days earlier)

In progress

Due to a certificate change for Zempler Bank (institutionId CASHPLUS_NWBKGB2L) on August 8th, existing consent may be lost - if this happens - please reconnect the account.

We apologize for the disturbance.

Fri, Aug 8, 2025, 12:10 PM(4 days earlier)

In progress

A certificate change will happen on August 14th for CEC_CECEROBU. It is possible existing consent may be lost - if this happens - please reconnect the account.

Thu, Aug 7, 2025, 08:15 AM(1 day earlier)

In progress

A certificate change will happen on August 13th for HSBC_NET_HSBCIE2D. It is possible existing consent may be lost - if this happens - please reconnect the account.

Wed, Aug 6, 2025, 08:01 AM(1 day earlier)

In progress

Chase Bank (CHASE_CHASGB2L) has been enabled, issue has been fixed and connection is working as expected.

Fri, Aug 1, 2025, 12:38 PM(4 days earlier)

In progress

Unfortunately there has been complications with Chase Bank (CHASE_CHASGB2L) and connection has been disabled until it's fixed. We apologize for the disturbance.

Thu, Jul 31, 2025, 01:06 PM(23 hours earlier)

In progress

CHASE Bank GB (CHASE_CHASGB2L) has been enabled and everything is working as expected.

Thu, Jul 31, 2025, 12:38 PM(27 minutes earlier)

In progress

Due to certificate change there will be Downtime with CHASE Bank GB (CHASE_CHASGB2L)
3pm - 3:25 (GMT+3)

Thu, Jul 31, 2025, 12:00 PM(38 minutes earlier)

In progress

Due to certificate change consents for BRED Banque Populaire (BRED_BREDFRPP) will expire on 6.08.25.
Please reconnect the accounts in advance.
We apologize for the disturbance.

Wed, Jul 30, 2025, 09:12 AM(1 day earlier)

In progress

Tue, Jul 29, 2025, 10:42 AM(22 hours earlier)

Scheduled

Due to yearly certificate update Alpha FX Bank(ALPHA_FX_APAHGB2L) account consents will expire. Please reconnect the accounts latest until 8.08.25.

We apologize for the disturbance.

Tue, Jul 29, 2025, 09:49 AM(52 minutes earlier)

In progress


On July 23rd at12:00. UTC we will update our certificates for

DJURSLANDS_CORP_DJURDK22
DJURSLANDS_DJURDK22
JYSKEBANK_CORP_JYBADKKK
JYSKEBANK_JYBADKKK
KREDITBANKEN_AAKRDK22
KREDITBANKEN_CORP_AAKRDK22
LANDBOBANK_CORP_RINGDK22
LANDBOBANK_RINGDK22
NORDFYNS_CORP_NSBKDK21
NORDFYNS_NSBKDK21
SKJERN_BANK_CORP_SKJBDK22
SKJERN_BANK_SKJBDK22
SPAREKASSEN_CORP_SWESDK22
SPAREKASSEN_SWESDK22
SYDBANK_CORP_SYBKDK22
SYDBANK_SYBKDK22


This will result in a short downtime and after the downtime, all the connected accounts will need to be reconnected.

Wed, Jul 16, 2025, 01:42 PM(1 week earlier)

In progress

BRD_GROUPE_SOCIETE_GENERALE_RO_BRDEROBU certificate change has been delayed due to more testing required, further updates will happen as soon as a new date will be set.

Wed, Jul 16, 2025, 09:14 AM(4 hours earlier)

In progress

Tue, Jul 8, 2025, 07:43 AM(1 week earlier)

Scheduled

On 16 July @9am UTC we will update our certificates for BRD_GROUPE_SOCIETE_GENERALE_RO_BRDEROBU

This will result in a short downtime and after the downtime, all the connected accounts will need to be reconnected.

Sun, Jul 6, 2025, 11:26 AM(1 day earlier)

Scheduled

In this maintenance we will share updates and impact of our yearly eiDAS certificate update for all our institutions.

09/06/2025
AIRBANK_AIRACZPP - The certificate update will require all connected accounts to be reconnected after the changes are deployed @ 9:00 GMT

Mon, Jun 30, 2025, 08:36 AM(6 days earlier)