HSBC and First Direct connection issues.
Resolved·Degraded performance

All disabled institutions have been re-enabled.

Thu, May 1, 2025, 08:04 AM
(1 week ago)
·
Affected components
Updates

Resolved

All disabled institutions have been re-enabled.

Thu, May 1, 2025, 08:04 AM

Monitoring

The issue has been fixed and all disabled institutions have been re-enabled

Thu, May 1, 2025, 06:51 AM(1 hour earlier)

Investigating

Multiple HSBC and First Direct institutions are experiencing issues, we have currently disabled the following ASPSP’s while we investigate. FIRST_DIRECT_MIDLGB22 HSBC_HBUKGB4B HSBC_BUSINESS_HBUKGB4B HSBC_KINETIC_HBUKGB4B HSBC_NET_HBUKGB4B

Wed, Apr 30, 2025, 05:39 AM(1 day earlier)