Resolved
This incident is fully resolved.
All bank in Portugal are fully operational and no new timeouts have been observed.
Monitoring
A fix has been applied and banks in Portugal no longer experience timeout issues.
We will continue to monitor the performance before closing this incident.
Investigating
We have now re-enabled the affected banks on production and are monitoring the performace.
Investigating
Due to a further increase of errors for the affected institutions we have temporarily disabled these.
We will attempt to re-enable them tomorrow to see if stability has improved.
In the meanwhile we are in contact with SIBS and are awaiting their input.
Investigating
After deploying the fix, we are still experiencing the same behavior as before. As a result, we are disabling the following institutions: BANCO_ATLANTICO_BAPAPTPL BANCO_PORTUGUES_DE_GESTAO_BPGPPTPL BANCOACTIVOBANK_ACTVPTPL BANCOBPI_BBPIPTPL BANKINTER_BKBKPTPL BIG_BDIGPTPL BIGES_IGSEESMM CAIXA_AGRICOLA_BOMBARRAL_CERTPTP1 CAIXA_AGRICOLA_TORRES_VEDRAS_CTIUPTP1 CAIXA_CENTRAL_DE_CREDITO_AGRICOLA_CCCMPTPL CAIXA_DE_CREDITO_AGRICOLA_MUTUO_DA_CHAMUSCA_CCCHPTP1 CAIXA_DE_CREDITO_AGRICOLA_MUTUO_DE_LEIRIA_CDCTPTP2 CAIXA_DE_CREDITO_AGRICOLA_MUTUO_DE_MAFRA_CDOTPTP1 CAIXA_ECONOMICA_DA_MISERICORDIA_CEMAPTP2 CAIXA_GERAL_DEPOSITOS_CGDIFRPP CAIXA_GERAL_DEPOSITOS_CGDIPTPL COFIDIS_CFFIPTP1 EUROBIC_BPNPPTPL MONTEPIO_MPIOPTPL NOVOBANCO_ACORES_BESAPTPA NOVOBANCO_BESCPTPL SANTANDER_PT_TOTAPTPL MILLENIUMBCP_BCOMPTPL UNICRE_UIFCPTP1XXX We have contacted SIBS and are currently waiting for their input. We will keep you updated as we receive more information.
Investigating
We are re-opening this incident once again.
After deploying the fix, everything seemed to work as expected, however over the last couple of hours we again see the same behaviour, as before the fix.
We are now continuing our investigation and waiting for SIBS teams input.
Resolved
After deploying the changes for the rest of the SIBS institutions we believe that we have solved the issue, the timeout errors are no longer present in our logs.
The incident has been resolved.
Monitoring
After deploying the fix it seems to have solved the TimoutError issue for BANCOBPI_BBPIPTPL.
We will now toll out the same change for the following institutions and continue monitoring:
NOVOBANCO_BESCPTPL
BANCOACTIVOBANK_ACTVPTPL
CAIXA_GERAL_DEPOSITOS_CGDIPTPL
SANTANDER_PT_TOTAPTPL
MILLENIUMBCP_BCOMPTPL
CAIXA_CENTRAL_DE_CREDITO_AGRICOLA_CCCMPTPL
MONTEPIO_MPIOPTPL
BANKINTER_BKBKPTPL
EUROBIC_BPNPPTPL
CAIXA_DE_CREDITO_AGRICOLA_MUTUO_DE_LEIRIA_CDCTPTP2
BIG_BDIGPTPL
UNICRE_UIFCPTP1XXX
NOVOBANCO_ACORES_BESAPTPA
Identified
As a part of the solution for SIBS issue we will shortly deploy changes for BANCOBPI_BBPIPTPL, after the deployment AccessExpired error might be returned to any API calls.
To restore the access, please reconnect the affected accounts.
Identified
We are still seeing quite high error numbers for SIBS banks.
We are in touch with the technical team at SIBS, and we believe that we have identified the root cause of the issue.
Once we get the confirmation from SIBS team, we will be able to take further steps to resolve the problem.
Resolved
The error spike from SIBS institutions has dropped, the issue is considered resolved.
Investigating
We are aware of the rise in time out errors returned by Portugeese institutions. SIBS a provider that offers open banking connections to Portuguese banks seem to experience slow server response times, which can lead to errors when requesting data via our API. We are in touch with SIBS team and are waiting for their update on the matter.