Resolved
The banks API provider has gotten back to us, confirming that they have identified and resolved the issue. We are closing this incident.
Investigating
At the moment we have reenabled all affected banks, we can still see that the API provider for these institutions are returning errors to some requests. However most requests are going trough Reconnecting the affected accounts might solve the issue. We are still waiting for a response from the open banking API provider for the affected institutions regarding the issue.
Investigating
Starting 1st of April @ 1:00 AM UTC Multiple Spanish banks are experiencing degraded performance and are returning erros to API requests, we have disabled the following institutions:
BANCSABADELL_BSABESBB
BBVA_BBVAESMM
CAIXABANK_CAIXESBB
SANTANDER_BSCHESMM
Other Spanish and Portuguese institutions that are not listed may also encounter issues. We have reached out to the technical team that provides open banking services for the affected banks.